XFCE 4.12 on EPEL7

Adam Miller maxamillion at fedoraproject.org
Fri Mar 6 04:01:16 UTC 2015

On Wed, Mar 4, 2015 at 2:04 PM, Martin Sourada <martin.sourada at gmail.com> wrote:
> Hi all,
> are there any plans on getting Xfce 4.12 on epel7 (e.g. copr repo)? I've
> been able to mockchain build pretty much everything sans:

For whatever it's worth I put together a copr tonight for kicks but
for whatever reason it seems to have caused yum to puke:


[root at localhost ~]# yum update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.hmc.edu
 * epel: fedora-epel.mirror.lstn.net
 * extras: yum.tamu.edu
 * updates: mirrors.chkhosting.com
Resolving Dependencies
--> Running transaction check
---> Package Thunar.x86_64 0:1.6.3-2.el7 will be updated
---> Package Thunar.x86_64 0:1.6.6-1.el7.centos will be an update
---> Package exo.x86_64 0:0.10.2-8.el7 will be updated
---> Package exo.x86_64 0:0.10.2-9.el7.centos will be an update
---> Package garcon.x86_64 0:0.2.1-5.el7 will be updated
---> Package garcon.x86_64 0:0.4.0-2.el7.centos will be an update
---> Package libxfce4ui.x86_64 0:4.10.0-12.el7 will be updated
---> Package libxfce4ui.x86_64 0:4.12.0-2.el7.centos will be an update
---> Package libxfce4util.x86_64 0:4.10.1-2.el7 will be updated
---> Package libxfce4util.x86_64 0:4.12.1-1.el7.centos will be an update
---> Package orage.x86_64 0:4.10.0-4.el7 will be updated
---> Package orage.x86_64 0:4.10.0-5.el7.centos will be an update
---> Package xfce4-appfinder.x86_64 0:4.10.1-2.el7 will be updated
---> Package xfce4-appfinder.x86_64 0:4.12.0-1.el7.centos will be an update
---> Package xfce4-panel.x86_64 0:4.10.1-6.el7 will be updated
---> Package xfce4-panel.x86_64 0:4.12.0-2.el7.centos will be an update
---> Package xfce4-power-manager.x86_64 0:1.4.1-4.el7 will be updated
---> Package xfce4-power-manager.x86_64 0:1.4.3-2.el7.centos will be an update
---> Package xfce4-session.x86_64 0:4.10.1-7.el7 will be updated
---> Package xfce4-session.x86_64 0:4.12.0-1.el7.centos will be an update
---> Package xfce4-session-engines.x86_64 0:4.10.1-7.el7 will be updated
---> Package xfce4-session-engines.x86_64 0:4.12.0-1.el7.centos will
be an update
---> Package xfce4-settings.x86_64 0:4.10.1-3.el7 will be updated
---> Package xfce4-settings.x86_64 0:4.12.0-4.1.el7.centos will be an update
---> Package xfconf.x86_64 0:4.10.0-7.el7 will be updated
---> Package xfconf.x86_64 0:4.12.0-1.el7.centos will be an update
---> Package xfdesktop.x86_64 0:4.10.2-3.el7 will be updated
---> Package xfdesktop.x86_64 0:4.12.0-1.1.el7.centos will be an update
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 355, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 217, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1202,
in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 891,
in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing =
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 1023,
in _resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 349,
in _processReq
    CheckDeps, missingdep = self._requiringFromTransaction(po,
requirement, errormsgs)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 656,
in _requiringFromTransaction
    msg = self._err_missing_requires(requiringPo, requirement)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 379,
in _err_missing_requires
    msg = self.dsCallback.format_missing_requires(reqPo, reqTup)
  File "/usr/share/yum-cli/output.py", line 2923, in format_missing_requires
    msg += _('\n    Requires: %s') % (ui_req,)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position
0: ordinal not in range(128)

.... So this will be fun to sort out, but that's a task for another
day. If anyone know what's going on here though that'd be awesome.


> pragha-1.2.2-5.fc20.src.rpm (missing deps, more than one, haven't tried
> yet rebuilding them all)
> ristretto-0.8.0-1.fc23.src.rpm (missing deps for libappstream-glib
> which is unbuildable on epel7: too old glib, but fails late in build
> process)
> libxfcegui4-4.10.0-7.el7.src.rpm
> xfce4-timer-plugin-0.6.1-17.el7.centos.src.rpm
> xfce4-radio-plugin-0.5.1-10.el7.centos.src.rpm
> xfce4-quicklauncher-plugin-1.9.4-19.el7.centos.src.rpm
> xfce4-cpufreq-plugin-1.0.0-11.el7.centos.src.rpm
> Haven't tried the functionality though yet.
> Regards,
> Martin
> _______________________________________________
> xfce mailing list
> xfce at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/xfce

More information about the xfce mailing list