That is great that you have a work around for rawhide, but since I am running f12, I am more interested at the moment in the rack version downgrade there.  Should I just file a BZ against the Rack gem, or have you already spoken to the maintainer?  FYI, just doing a little more poking now, there are others outside fedora land who have hit this.  I have links below for some of the discussion (as recent as 2 days ago), but the gist is that rails does not want to guarantee it runs on >1.0.x because rack could introduce api breakage.  This means we can not expect rails to be changing their gemspec to accommodate a wider range of versions, and a ticket has been filed against rubygems itself.  Also, there is talk of rails using bundler to get around this issue, which, from the little I know about it, screams maven (and therefore makes me think there will be even more issues coming up for rails in fedora).  For instance, if you try to run a rails app in thin (which is now in fedora), and it loads rack 1.1 (it will load the latest you have installed), then rails will die because it tries to load 1.0.1 after 1.1 is already loaded.

rails position, explained by core commiter, yehuda katz:

rubygems ticket:

On Tue, Feb 23, 2010 at 9:41 PM, Mamoru Tasaka <> wrote:
Mamoru Tasaka wrote, at 02/24/2010 11:06 AM +9:00:
> Jason Guiditta wrote, at 02/24/2010 06:47 AM +9:00:
>> I am running Fedora 12 with Rails 2.3.4 installed.  Everything was
>> working fine, then last night I got an update from yum for Rack 1.1.
>>  After installing that, my working rails apps failed to load.  Creating
>> a new test app yielded:
>> /usr/lib/ruby/site_ruby/1.8/rubygems.rb:827:in `report_activate_error':
>> RubyGem version error: rack(1.1.0 not ~> 1.0.0) (Gem::LoadError)
>> Has anyone else hit this issue?  If more detail is needed, let me know.
>>  Thanks,
>> -j
> Well, as I already posted on
> ,
> rack 1.1.0 is not compatible with rails 2.3.x.
> I added some workarounds on rawhide rails, however for F-12 we may have to
> consider to downgrade rack to 1.0.0.

Well, actually workaround is in rubygem-actionpack, which rubygem-rails depends on.
Also please check
(already marked as "CLOSED RAWHIDE")

ruby-sig mailing list