Dan Kenigsberg has posted comments on this change.
Change subject: Adding flowID ......................................................................
Patch Set 5: I would prefer that you didn't submit this
(1 inline comment)
please remember my little refactoring patch. you may want to take it *before* your own patch, so that you do not have to duplicate code.
.................................................... File vdsm/BindingXMLRPC.py Line 139: threadLocal.flowID = self.headers.get(constants.HTTP_HEADER_FLOWID) it makes sense for this to be a CONSTANT, particularly if used twice. However, there is no justification to throw it into the global trash can called "constants". Use a module-local _CONSTANT instead.
-- To view, visit http://gerrit.ovirt.org/1221 To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: comment Gerrit-Change-Id: I6c818d7a90fea41663fd48620ac9718451a8662f Gerrit-PatchSet: 5 Gerrit-Project: vdsm Gerrit-Branch: master Gerrit-Owner: Douglas Schilling Landgraf dougsland@redhat.com Gerrit-Reviewer: Dan Kenigsberg danken@redhat.com Gerrit-Reviewer: Douglas Schilling Landgraf dougsland@redhat.com Gerrit-Reviewer: Moti Asayag masayag@redhat.com Gerrit-Reviewer: Saggi Mizrahi smizrahi@redhat.com