Nir Soffer has posted comments on this change.
Change subject: tests: Add a live merge functional test ......................................................................
Patch Set 1:
(1 comment)
Partial review
http://gerrit.ovirt.org/#/c/29824/1/tests/functional/utils.py File tests/functional/utils.py:
Line 237: def getVolumeInfo(self, sdId, spId, imgId, volId): Line 238: result = self.vdscli.getVolumeInfo(sdId, spId, imgId, volId) Line 239: return result['status']['code'], result['status']['message'],\ Line 240: result['info'] Line 241:
quite a bit of code duplication. Usually I don't like metaprogramming, but
There is indeed code duplication here, but Adam is trying to add a test, not fix the world.
The change you suggest or similar change should be fixed in a separate patch fixing all the utilities in this file, not only the few new calls added by this patch.
Please don't block important test just because it can be better. Line 242: def createVolume(self, sdId, spId, imgId, size, volFormat, preallocate, Line 243: diskType, volId, desc, baseImgId, baseVolId): Line 244: result = self.vdscli.createVolume(sdId, spId, imgId, size, volFormat, Line 245: preallocate, diskType, volId, desc,