UsrMove feature breaking "yum upgrade" upgrades from older releases to F17?

Nils Philippsen nils at
Fri Jan 27 13:18:37 UTC 2012

On Thu, 2012-01-26 at 14:51 +0000, Peter Robinson wrote:
> On Thu, Jan 26, 2012 at 2:43 PM, Harald Hoyer <harald at> wrote:
> > Am 25.01.2012 23:48, schrieb Peter Robinson:
> >> Hi All,
> >>
> >> So I saw a rpm update and a number of other builds today when dealing
> >> with various packaging bits. Checking the update [1] and reading the
> >> attached bug [2] I was a little shocked to find that "yum upgrade"
> >> between releases would be explicitly broken due to this feature.
> >
> > Not really true. "yum upgrade" will be supported, but it needs a little help
> > with a special initramfs and an additiona
> So why isn't it documented as such?

It is, the feature page mentions the script, the tentative preparation
steps on the yum upgrade page describe the details.

Nils Philippsen      "Those who would give up Essential Liberty to purchase 
Red Hat               a little Temporary Safety, deserve neither Liberty
nils at       nor Safety."  --  Benjamin Franklin, 1759
PGP fingerprint:      C4A8 9474 5C4C ADE3 2B8F  656D 47D8 9B65 6951 3011

More information about the devel mailing list