FC17alpha, evolution, ati card, kernel 3.3.0-rc6 and me going crazy...

Peter A loony at loonybin.org
Thu Mar 8 03:56:04 UTC 2012


I think I'm losing my mind. I recently got stuck with a Dell M6600. Its 
a really nice machine but when I installed F17 from the alpha dvd and 
updated it over the weekend, graphics was insanely slow (e.g. 1920x1080 
screen with just 4 open terminals would take 3 seconds to shift focus 
from one terminal to the next). Today's kernel update to 3.3.0-rc6 fixes 
the performance but now I have an even crazier issue.

The issue effects only Evolution it seems - all other software I tried 
works fine (that's anything from firefox to libreoffice to gimp to 
ancient stuff like xv from an rpm built in 99). My desktop is KDE with 
OpenGL rendering but most effects turned off.

The issue results in the tree menu showing the mail boxes on the left 
being shifted about 75px up. However, the cursor location (e.g. 
highlighted folder when drag and drop) is what the screen should be. In 
other words, I need to move the cursor about 75px further down to select 
the correct folder. I wanted to talk to some friends about this so I 
took a screenshot - and the screenshot shows up perfect. 
(http://www.loonybin.org/evo1.jpg) However, if I do a screengrab of the 
root window, the corruption is visible. 
(http://www.loonybin.org/evo2.jpg). Both screenshots were taken less 
than a second apart with import.

So who do you think the problem lies with?

Application? Evolution doesn't seem to be the issue since I can open 
Xnest and then start evolution there and it draws correctly. It also 
looks fine on the screen shot when I import just that one window...
xorg driver? I downgraded to the previous xorg rpm 
(xorg-x11-drv-ati-6.14.3-10.20120206git36c190671.fc17.x86_64) without 
Kernel? I rebooted into -rc5 without change... Everything went back to 
being dead slow - but the evolution issue stayed...
KDE/kwin compositing? There were kde updates since the last time it 
worked and when it broke... Today's updates to 4.8.1 didn't make a 
difference either.
Leaves us with either user error (always a possibility) or there is 
something else going on...

Any suggestions?



More information about the devel mailing list