ld terminated with signal 9 [Killed]

Dan Horák dan at danny.cz
Thu Feb 19 19:12:52 UTC 2015

On Thu, 19 Feb 2015 19:51:38 +0100
Marek Skalický <mskalick at redhat.com> wrote:

> Hi,
> I were trying to compile f22 mongoDB package with enabled
> _hardened_build . And it always failed with:
> collect2: fatal error: ld terminated with signal 9 [Killed]
> compilation terminated.
> scons: *** [build/linux2/ssl/use-system-all/usev8/mongo/mongod] Error
> 1 scons: building terminated because of errors.
> RPM build errors:
> error: Bad exit status from /var/tmp/rpm-tmp.NWmAoC (%build)
>     Bad exit status from /var/tmp/rpm-tmp.NWmAoC (%build)
> Child return code was: 1
> (log file
> https://kojipkgs.fedoraproject.org//work/tasks/8167/8998167/build.log)
> I've tried it four times and compilation failed always in different
> place (linking different binaries). Without enabled hardening it
> builds fine. (On 9 Jan with a little older version I tried scratch
> hardened build and it also worked fine)
> Where could be problem? Is it possible, that there isn't enough
> memory?

yes, looks as an out-of-memory situation, you can try switching to -g1
in CFLAGS for lesser debug infos (see eg. webkitgtk4) or using -j1 for
make if there would be more jobs competing for memory


PS: please send the link to the task, not to the log directly

More information about the devel mailing list