Status of effort

Murray McAllister murray.mcallister at
Tue Dec 18 21:39:34 UTC 2007

On Dec 19, 2007 6:21 AM, Karl Larsen <k5di at> wrote:
> Here is what worked and did not today:
> [karl at k5di ~]$ gpg -K
> /home/karl/.gnupg/secring.gpg
> -----------------------------
> sec   1024D/FA8EC752 2007-12-17
> uid                  Karl Larsen (For Fedora Doc work) <k5di at>
> ssb   1024g/9A70DE59 2007-12-17
> [karl at k5di ~]$
> [karl at k5di ~]$ gpg --fingerprint
> /home/karl/.gnupg/pubring.gpg
> -----------------------------
> pub   1024D/FA8EC752 2007-12-17
>       Key fingerprint = 28AC 2D41 EF25 0417 7166  DD81 44BD ABFC FA8E C752
> uid                  Karl Larsen (For Fedora Doc work) <k5di at>
> sub   1024g/9A70DE59 2007-12-17
>     I do have a /home/karl/.ssh/ directory and it has:
> [karl at k5di .ssh]$ ls
> id_dsa  known_hosts
>     I think when I put the full address of id_dsa it works on the
> register page. But FA8EC752 has never worked in the pgpID entry on the
> register form. This may be because I'm not on the MIT list?
>     Here after I got the dam thing to work it sent FA8EC752 to MIT in
> nothing flat! Yesterday it thought and thought and then provided an
> error message. Of course I used the instructions exactly as written on
> the web page.

You mentioned this worked the other day. Once you have uploaded your
keys to MIT you don't have to do it again. Do you remember what the
error was? Perhaps it was because you already have your keys there...

>     The point I want to make is that sometimes you can't reach MIT and
> that MUST be explained in the Instructions.

This may have been a home internet/router problem. Most home routers
sometimes/eventually allow connections on ports, even if you
specifically block said port :(
> Registration:
>     Went to the web page to register and after correcting some problems
> it went through. So I am a registered member of the Doc Group, whatever
> that might mean, but for certain my gpg and ssh numbers were good enough
> to register. For certain the registration job includes going to
> and finding my stuff.
> Contributor License Agreement:
>     I learned that I must fill out and send back a Contributor License
> Agreement but when I tried to it I got an error. This is what happened:
>  [karl at k5di ~]$ gpg -a --sign fedora-icla-karl.txt
> gpg: no default secret key: secret key not available
> gpg: signing failed: secret key not available
> [karl at k5di ~]$
> I have no idea what a "default secret key" is and I guess I need one but
> no-where in the Instructions does it say do this to make a default
> secret key.
> Summary:
>     There are serious errors in the Instructions. I have no way to send
> the CLA to Fedora except by printing the thing and signing it in ink and
> mail it to the address given.
>     I have no way to join this Doc and I have D/L "seahorse" and it
> seems to work. It found both of my GPG and SSH passwords.
>     I will tear up my registration and delete both my keys and re-do it
> with "seahorse" ONLY if you agree to remove all the manual Terminal
> Instructions. I ask this because what I did does not work. The new GUI
> software uses gnupg2 which must be required now.

I'm sorry to hear you had trouble with the terminal instructions. They
have worked fine for thousands before you. What specifically was wrong
with them, and where were your problems (I have already noted signing
and sending to mit - but that should work, and if it doesn't, then it
is most likely a problem with your machine.).

Hope that helps, probably doesn't :P



pub   1024D/81B3FDEB 2007-09-19 [expires: 2008-09-18]
Key fingerprint = 4ED9 9907 5BF0 4132 2B46  20D1 C0C6 362D 81B3 FDEB
Murray McAllister (Fedora Docs Project / mdious) <murray.mcallister at>
sub   2048g/B04CFA0C 2007-09-19 [expires: 2008-09-18]

More information about the docs mailing list