[PATCH] build-locale-archive sometimes created empty archives

Carlos O'Donell carlos at redhat.com
Thu Sep 17 14:39:04 UTC 2015

On 09/17/2015 10:23 AM, Mike FABIAN wrote:
> "Carlos O'Donell" <carlos at redhat.com> さんはかきました:
>> On 09/17/2015 10:01 AM, Mike FABIAN wrote:
>>> build-locale-archive sometimes created empty archives
>> How did you test this?
>> Did you try the resulting binary and verify it still works?
> I installed the rpms I built with mockbuild for F23 on
> Fedora-Workstation-netinst-x86_64-23_Beta.iso in qemu-kvm
> and tried 
> sudo rpm -Uhv -D "_install_langs en_US" glibc-common-2.22-2.fc23.x86_64.rpm --force
> with various different values for _install_langs and it created
> the locale-archive as expected.
> I also tried the binary directly doing something like:
> sudo cp /usr/lib/locale/locale-archive /usr/lib/locale/locale-archive.tmpl
> /usr/sbin/build-locale-archive  --install-langs en_US
> This worked fine with *both* the old *and* the new binary.
> (I guess the old binary works accidentally).

The old binary works because of the way physical systems tend to have
clean pages with zeroes on them. While qemu, under memory pressure,
the applications tend to see dirty pages from malloc, and that can cause
things to fail. It's a common problem I've seen.

>> I imagine that if you ran the old binary through valgrind it would
>> raise a failure, but the new binary would not. Did you try that?
> I did not check that, trying it now ...

If valgrind comes up clean with the final build, please go ahead and
commit it to F23.


More information about the glibc mailing list