state of the askbot

Kevin Fenzi kevin at
Mon Jan 20 17:10:52 UTC 2014

On Mon, 20 Jan 2014 09:18:30 -0700
Kevin Fenzi <kevin at> wrote:

> ok, many more mutllang issues. ;( 

And solved. ;) 
> * If 'zh-tw': 'Traditional Chinese' is enabled it causes no questions
>   to be submittable. ;( 
> * If I remove that the new question form comes back up and I can
>   submit, but then they never show up correctly: 
> It just redirects to itself in a loop over and over. ;( 
> * When multilang is enabled and you ask a question, there's a "select
>   language" thing at the bottom, and it has just single letters in
> it. 
> Can you confirm those on your openshift instance? Or is it something
> with our local setup?
> Given these, I might punt on enabling in production, unless we can
> figure them out really really quickly. :) 

We had: 

     'zh-tw': 'Traditional Chinese',
     'en': 'English',
     'fr': 'French',
     'el': 'Greek',
     'ru': 'Russian',
     'es': 'Spanish'

But it turns out it's not just a dict... ;( 

This seems to be correct: 

gettext = lambda s: s
    ('es', gettext('Spanish')),
    ('en', gettext('English')),
    ('ru', gettext('Russian')),
    ('zh-tw', gettext('Chinese')),
    ('fr', gettext('French')),
    ('el', gettext('Greek')),

Now all the above 3 items seem solved. 

Please test more. ;) 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <>

More information about the infrastructure mailing list