Fresh install, no network

Patrick O'Callaghan pocallaghan at
Mon Nov 1 22:42:24 UTC 2010

On Mon, 2010-11-01 at 14:58 -0600, Michal Jaegermann wrote:
> On Sun, Oct 31, 2010 at 11:06:53PM -0430, Patrick O'Callaghan wrote:
> > On Sun, 2010-10-31 at 19:46 -0600, Michal Jaegermann wrote:
> > 
> > > The first "sanity check" is to configure your network interface
> > > static to make sure that the basic hardware/driver are healthy.
> > > One thing at a time.
> > 
> > That's fine, however the only effect of configuring a manual IP (outside
> > the pool managed by the DHCP server, which is also the router), plus
> > netmask, router etc. is that nmcli now says "connected"
> > and /var/log/messages no longer has DHCP errors,
> That is sort of expected. :-)  You are not using DHCP anymore.
> > but pinging the router
> > gets me "Destination unreachable" and several dropped packets.
> On an assumption that this interface is correctly configured (an
> address without typos, right network) that says something, doesn't
> it?  Your hardware appears to be ok, because of F13, so apparently
> its driver went south. 'lsmod' presumably lists it as loaded and in
> use, right?  The situation possibly generated some additional info
> in dmesg and/or /var/log/messages.  Did you check?  What
> 'ifconfig eth0' has to say about RX and TX?  It is not a great
> surprise that DHCP does not work, or works erraticaly, if your
> connection is basically shot.  That would be a serious bug.

ifconfig shows activity on the interface (RX and TX). I tried
hard-wiring the IP address and pinging the router. tcpdump (running on
the same machine) shows the ICMP requests and ARP "who-has" requests
from the router . After a while (several 10s of seconds) I start to see
ARP "is-at" replies, showing the correct MAC address, but still no ICMP

/var/log/messages shows nothing wrong except for DHCP timeouts when in
DHCP mode. dmesg shows the link going up, then into promiscuous mode
(for the tcpdump) plus the "no IPv6 routers" message that apparently
doesn't mean anything important (ip6tables is off and ipv6 is disabled
in s-c-network).


More information about the test mailing list