https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Bug ID: 1213258 Summary: Docker 1.6 needs tar but does not require it Product: Fedora Version: 21 Component: docker-io Assignee: ichavero@redhat.com Reporter: jpazdziora@redhat.com QA Contact: extras-qa@fedoraproject.org CC: adimania@gmail.com, admiller@redhat.com, golang@lists.fedoraproject.org, hushan.jia@gmail.com, ichavero@redhat.com, jchaloup@redhat.com, jperrin@centos.org, lsm5@redhat.com, mattdm@redhat.com, mgoldman@redhat.com, miminar@redhat.com, s@shk.io, thrcka@redhat.com, vbatts@redhat.com
Description of problem:
Starting container fails with fork/exec /usr/bin/tar: no such file or directory
Version-Release number of selected component (if applicable):
docker-io-1.6.0-0.1.rc6.fc21
How reproducible:
Seen once, assume deterministic.
Steps to Reproduce: 1. Build an image. 2. Run a container.
Actual results:
time="2015-04-20T03:35:12-04:00" level=fatal msg="Error response from daemon: Cannot start container 4df4e127d80dbfbf26a972a00f51085570fff275554979e80901ee93c7f69b29: [8] System error: [/usr/bin/tar -cf /var/lib/docker/tmp/4df4e127d80dbfbf26a972a00f51085570fff275554979e80901ee93c7f69b29725221613/_run.tar -C /var/lib/docker/devicemapper/mnt/4df4e127d80dbfbf26a972a00f51085570fff275554979e80901ee93c7f69b29/rootfs/run .] failed: : fork/exec /usr/bin/tar: no such file or directory"
Expected results:
No error, container runs.
Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Jan Pazdziora jpazdziora@redhat.com changed:
What |Removed |Added ---------------------------------------------------------------------------- CC| |jpazdziora@redhat.com
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
--- Comment #2 from Jan Pazdziora jpazdziora@redhat.com --- docker-io-1.6.0-2.git3eac457.fc21.x86_64 (and possibly earlier builds) have the Requires: tar.
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Russell Davies russell.davies@blakemere.ca changed:
What |Removed |Added ---------------------------------------------------------------------------- CC| |russell.davies@blakemere.ca
--- Comment #3 from Russell Davies russell.davies@blakemere.ca --- Same problem here.
For example. doing 'docker run --rm swarm create' results in a ': mainFATA[0002] Error response from daemon: : exit status 2 '. with the following noted in journalctl:
3:41 jeb docker[4548]: Cannot start container 134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101: [8] System error: [/usr/bin/tar -cf /var/lib/docker/tmp/134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101535370894/_tmp.tar -C /var/lib/docker/devicemapper/mnt/134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101/rootfs/tmp .] failed: /usr/bin/tar: /var/lib/docker/devicemapper/mnt/134815e0c72cffe4debf781fd52edaba548b6c82e39e2d74aabeb425fdcd7101/rootfs/tmp: Cannot open: No such file or directory May 13 18:23:41 jeb docker[4548]: /usr/bin/tar: Error is not recoverable: exiting now May 13 18:23:41 jeb docker[4548]: : exit status 2
Version 1.5 seems to work on Fedora 20, but fails if updated to 1.6 from the updates-testing.
Work-around seems to be to use 1.5. However, Fedora 21 only has 1.3 and 1.6 available in the repositories.
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
--- Comment #4 from Russell Davies russell.davies@blakemere.ca --- More complete diagnostics here: https://github.com/docker/swarm/issues/781#issuecomment-104158953
They says it's related to patches specific to Redhat/Fedora.
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Marcus Ramberg marcusramberg@gmail.com changed:
What |Removed |Added ---------------------------------------------------------------------------- CC| |marcusramberg@gmail.com
--- Comment #5 from Marcus Ramberg marcusramberg@gmail.com --- We are seeing this last version as well with docker 1.6 on RHEL7.1 - tar is installed, so it's failing in some other way. Not making the correct folders?
[root@ose3beta-node01 ~]# docker run openshift/hello-openshift Timestamp: 2015-05-22 00:50:15.957307284 +0200 CEST Code: System error
Message: [/usr/bin/tar -cf /var/lib/docker/tmp/5ad511352e37a517bc976c0492c49fe73e0d822ee61aa29ac4eee85d5c3abe24134539868/_tmp.tar -C /var/lib/docker/devicemapper/mnt/5ad511352e37a517bc976c0492c49fe73e0d822ee61aa29ac4eee85d5c3abe24/rootfs/tmp .] failed: /usr/bin/tar: /var/lib/docker/devicemapper/mnt/5ad511352e37a517bc976c0492c49fe73e0d822ee61aa29ac4eee85d5c3abe24/rootfs/tmp: Cannot chdir: No such file or directory /usr/bin/tar: Error is not recoverable: exiting now : exit status 2
Frames: --- 0: setupRootfs Package: github.com/docker/libcontainer File: rootfs_linux.go@30
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Brenton Leanhardt bleanhar@redhat.com changed:
What |Removed |Added ---------------------------------------------------------------------------- CC| |bleanhar@redhat.com
--- Comment #6 from Brenton Leanhardt bleanhar@redhat.com --- Hi Marcus,
I believe the issue mentioned in Comment #5 is https://github.com/openshift/origin/issues/2579 and unrelated to this bug.
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Ben Parees bparees@redhat.com changed:
What |Removed |Added ---------------------------------------------------------------------------- CC| |bparees@redhat.com
--- Comment #7 from Ben Parees bparees@redhat.com --- issue in comment 5 is also being tracked in bugzilla here: https://bugzilla.redhat.com/show_bug.cgi?id=1223662
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Daniel Walsh dwalsh@redhat.com changed:
What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED CC| |dwalsh@redhat.com Assignee|ichavero@redhat.com |lsm5@redhat.com
--- Comment #8 from Daniel Walsh dwalsh@redhat.com --- Should be fixed in docker-1.6.2/
https://bugzilla.redhat.com/show_bug.cgi?id=1213258
Daniel Walsh dwalsh@redhat.com changed:
What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |CLOSED Resolution|--- |CURRENTRELEASE Last Closed| |2015-07-15 17:23:36
golang@lists.fedoraproject.org