another upgrade, another disaster

Ralf Ertzinger fedora at
Sat Jun 2 19:32:42 UTC 2012


On Tue, 29 May 2012 16:42:30 -0400, Neal Becker wrote

> 1) Could I have actually recovered from this mess without a complete
> re-install?

There is a way to recover from (almost) all upgrade messes, although
it has several preconditions.

The first precondition is having a root file system on btrfs, the
second is that probably none of the code to actually do this exists

My upgrade went as follows:

/ is a btrfs, without any subvolumes, /boot is an ext3, /home is
an ext4.

I created a snapshot of /, calling the subvolume f16 and rebooted into
the snapshot (basically to see if that worked). It did. So I then created
a snapshot of f16 calling it f17 and booted into that, in runlevel 3.

Then I proceeded to follow the wiki instructions of how to update a running
system using yum. Despite the scary warnings that worked very well, usrmove
and all. 

If it had not, if it had failed at some point I always had the f16 snapshot
to fall back on (actually, I still have it as updating via yum does not
remove all the old kernels as anaconda does. And it still works).

Having a root file system that supports bootable snapshots is one of the
cooler things to have, and I look forward to the day that anaconda more or
less automatically supports what I have done manually.

(what is left to do is to remove the f16 files that live in the top btrfs
subvolume, which seems to be more equal than all the other subvolumes for
no discernable reason)

Wir wollen mehr Netto vom Brutto, mehr Nuss im Cornetto
                                           -- The Incredible Herrengedeck, FDP

More information about the devel mailing list