Suspend/resume broken on Lenovo laptops (Fedora 21 beta)

valent.turkovic at valent.turkovic at
Mon Nov 17 00:26:19 UTC 2014

On Mon, Nov 17, 2014 at 1:11 AM, valent.turkovic at
<valent.turkovic at> wrote:
> On Mon, Nov 17, 2014 at 1:04 AM, Andrew Lutomirski <luto at> wrote:
>> On Sun, Nov 16, 2014 at 4:01 PM, valent.turkovic at
>> <valent.turkovic at> wrote:
>>> Just a quick update - i got suspend/resume to once randomly work in
>>> LXDE environment, but after that again everytime it failed.
>>> Then I tried using "debugging" kernel on GRUB menu, and now each time
>>> I tried suspend/resume in all environments (GNOME 3, LXDE, Cinnamon,
>>> XFCE) it worked every time as expected.
>> This smells like a no_console_suspend and/or whatever the new drm or
>> i915 fast suspend/resume thing is.  Are there interesting boot
>> parameters that differ between working and non-working configurations?
>> --Andy
> I'll check boot parameters and reply a bit later, but I noticed that
> now that suspend/resume works it is a bit slower to suspend. On
> "normal" kernel suspend is instant, when I enter "pm-suspend" or press
> suspend via GUI screen just goes black right away.
> With "debugging" kernel when I issue suspend command first I see lock
> screen, then screen goes black, then it blinks once more with lock
> screen and then it goes off.

@Andrew I see no difference in boot kernel parameters -

More information about the devel mailing list