Docker and gcc-go

Jakub Cajka jcajka at redhat.com
Thu Apr 2 14:50:15 UTC 2015


Hello,
   as gcc5 is in Fedora22+ it is possible to build docker and its BRs using gcc-go with small changes to the spec files. Not only on x86_64, but also on ppc64le, even on s390x(sharkcz tried) and ppc64. It crashes/hangs sometimes(I'm looking in to it) but works on x86_64 and ppc64(le) most of the time :) (haven't done any extensive testing yet) and haven't tried s390x yet.
 
Github repo with modified spec files of docker and its BRs:

  https://github.com/jcajka/fedora-docker-gccgo

SRPMS:

  https://jcajka.fedorapeople.org/srpms/

x86_64 COPR repo(f22/f23):

  https://copr.fedoraproject.org/coprs/jcajka/docker-gccgo/

ppc64(le) fedorapeople.org repo(f22):

  https://repos.fedorapeople.org/repos/jcajka/docker-gccgo/

ppc64(le) base images(just to test it ;) ):
 
  docker pull jcajka/fedora22-ppc64[le] (I hope images are there as they are not showing up in webUI)

  (were generated using https://github.com/docker/docker/blob/master/contrib/mkimage-yum.sh modified to install also dnf(yum), would be great to have base images available same way as on primary)

s390x coming soon :)

It is definitely not production ready and needs lots of testing/debugging. Looking forward for any feedback.

Jakub ńĆajka




   
   
  


More information about the devel mailing list