(Rawhide users) Fedora 22 branching: What You Need To Know

Felix Miata mrmazda at earthlink.net
Thu Jul 10 21:26:01 UTC 2014

On 2014-07-10 13:33 (GMT-0700) Adam Williamson composed:

> On Thu, 2014-07-10 at 04:45 -0400, Felix Miata wrote:

>> ISTR many times in the past having trouble turning onto the fork instead of
>> keeping on Rawhide, and solving the dilemma with something along the lines of:

>> # rpm -e --nodeps fedora-release-rawhide
>> # rpm -Uvh fedora-release-<post-fork>

>> When I saw the post I replied to I thought finally the forking would no
>> longer be vexing me.  :-(
> I *think* this shouldn't be an issue with the new fedora-release split,
> but I haven't read that whole thread or the spec files, so I can't be
> definitive. I'll try and keep an eye on how it shakes out and keep the
> wiki instructions up to date.
I tried to proceed with my old way, but here's the result:

# yum clean all
# rpm -qa | grep fedora
Loaded plugins: versionlock

#yum upgrade
 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

File /var/cache/yum/x86_64/21/fedora/metalink.xml does not exist
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-21&arch=x86_64 error was
No repomd file

/var/cache/yum/x86_64/21/rawhide contains a repomd.xml of same timestamp and size as
but they diff vastly different. Changing to the other changed nothing on subsequent yum
upgrade attempt. yum-config-manager --disable fedora and yum-config-manager --enable
rawhide also did nothing to help. Yum repolist all produces the same error text. Apparently
yum <anything> produces the same error text.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/

More information about the test mailing list